Message Board -  Archive

[ Login ] [ Create Account ]
[ Board List ] [ View Board ] [ Post Reply ]
  Author  Subject: Re: disabling UDMA on freebsd or linux
Archive  

Posted on 07-10-2003 10:11 p.m. ET  reply

Original Poster: Mark Krentel

> i found out the problem with my drive was the UDMA and how do i go about
> disabling it on freebsd (just installed last night) or even on linux.
> i looked in the BIOS but its a compaq so its limited i did disable what i
> could but it still gives me UDMA errors.

Well, I don't have any UDMA disks (that I know of :-), so I can only
offer some general suggestions.

What kinds of error messages are you seeing? Most importantly, when
do they happen? Does the machine boot ok? Did the install finish ok?

In FreeBSD, whatever can be adjusted is probably done via sysctl or
atacontrol. Or maybe with a kernel option, but I didn't find anything
relevent in LINT. "sysctl -a | grep -i dma" reports:

hw.ata.ata_dma: 1
hw.ata.atapi_dma: 0

So, I guess you could turn off all DMA with the first one.
See the man pages for sysctl(8), sysctl.conf(5) and ata(4).

Probably atacontrol(8) makes more sense. The man page says that
"atacontrol mode ..." will set the transfer mode, but I'm not sure
what you want to set it to. I guess ata(4) gives some values.

But I'm not sure of the timing for these settings. If you get errors
during the boot, it may not get far enough to run sysctl or atacontrol

In Linux, I guess you would use sysctl or the /proc file system.

And don't completely rule out hardware issues like cabling.

--Mark

< Previous 1 Next >

Site Contents