Message Board -  Archive

[ Login ] [ Create Account ]
[ Board List ] [ View Board ] [ Post Reply ]
  Author  Subject: disabling UDMA on freebsd or linux
Archive  

Posted on 07-11-2003 01:26 p.m. ET  reply

Original Poster: DMA linux/bsd errors

Had that probem with a hard drive that was on same IDE channel as a CD-Rom
(master-slave), only resolved itself when I turned DMA off in BIOS and used
PIO modes instead (or took the CD-rom off that IDE channel). Linux/BSD
kernels and modules are tuned to autodetect DMA settings, at least during
install, and not sure how deeply embedded the DMA controls are (i.e. maybe it
is difficult to turn DMA off, through Linux via software, and force the
machine to work with PIO modes instead, for drives where BIOS may be putting
DMA modes up first). DMA is supposed to be a performance increase, but
especially for older drives, highest PIO modes will be fine.

Sounds like it is difficult to get into the bios on your proprietary Compaq.
Some systems in the past have BIOS software that you can run, after booting
up the machine, that modify the BIOS settings using software - i.e. not from
the BIOS system itself at boot time. Maybe there is a utility for your system
that Compaq makes available?

Or if someone knows how to turn off DMA in Linux/BSD and actually force PIO
modes instead? Mark's message might be on that track.

Another thing to try, and this may not even help, plus it requires a
purchase, is to put a basic PCI IDE controller card into your system. SIIG,
for example, makes inexpensive ones that have the Silicon Image chipset which
is typically auto-recognized by recent Linux versions (not sure about FreeBSD
with that). I have a RH 9 system with a PCI IDE card that controls 2 drives
(UDMA) set as a software raid set in Linux and then I use the motherboard IDE
for the CD-Rom - no errors. Good luck with your system config

< Previous 1 Next >

Site Contents