Message Board -  Archive

[ Login ] [ Create Account ]
[ Board List ] [ View Board ] [ Post Reply ]
  Author  Subject: mount HD with ntfs file system
Archive  

Posted on 06-15-2003 11:26 p.m. ET  reply

Original Poster: nahmin horwitz

Thank you Jym, your first suggestion:

try >mount -t ntfs -o umask=022 /dev/hda2 /mnt/DOS_hda2

works!

4 questions:

Q1] you said:

You cannot change anything on a read-only filesystem, which is precisely the
reason why it is called "read-only". You can only read from it, and to change
something, you would have to be able to write to it.

I thought read-only meant that after mounting the internal HD which uses ntfs
file system, I could not transfer any files to that HD. But if I copy a file
foo.doc from that HD to my home directory on the second HD which contains the
linux file system then that copy is in a file system that is not read-only. So
how come the copy in my home directory is still read-only?

Q2] you said

However, all is not lost. According to the man page for the 'mount' command,
by default on the ntfs filesystem, "files are owned by root and not readable
by somebody else", but there are options for changing user and group
ownership, as well as setting the umask (which determines permissions). So,
try the following mount command line, and see if that gives you permission to
read the files.

But when I tried to change permissions I was root, so why is

'not readable by someone else'

relevant?

Q3] You said to include in the mount command

-o umask=022

I looked at man mount and could not find umask as an option for ntfs, but
assuming it is an option, I guess you told me the left hand digit should be 0
so that the user could read/write/exe but why did you set the other two digits
to be 22?

Q4]Although I didn't need to try your second suggestion, how do I ask the
system the value of my uid?

Thanks.

< Previous 1 Next >

Site Contents