Message Board -  Archive

[ Login ] [ Create Account ]
[ Board List ] [ View Board ] [ Post Reply ]
  Author  Subject: Re: modem
Archive  

Posted on 03-11-2003 01:50 a.m. ET  reply

Original Poster: Mark Krentel

> I think my modem is configured right but I
> cant seem to get it to dial out. I am using a USR 5686 external.

There isn't much to go on here. The way you run PPP in Linux
is to copy the ppp-on, ppp-off and ppp-on-dialer scripts from
/usr/share/doc/ppp-2.4.1/scripts to /etc/ppp, edit them for your
configuration, and then start and stop PPP with ppp-on and ppp-off.
Have you tried that?

If that doesn't work, then we need more detail about what you've
tried, how far you get, where you get stuck, what the error message
is, etc, etc. You can also try a program like minicom to talk
directly to the modem with AT commands to verify that you have the
right device and Linux can talk to the modem.

One other important thing: make sure your modem is not a winmodem.
If it's external, then it's probably not, but you never know.
All bets are off it it's a winmodem.

And try the modem and PPP howtos:

http://www.syrlug.org/docs/HOWTO/Modem-HOWTO.html
http://www.syrlug.org/docs/HOWTO/PPP-HOWTO/index.html

P.S. The ppp-on and ppp-on-dialer scripts are a security hole because
they put your ISP's user name and password into environment variables
(you can read another process's environment with ps). This doesn't
really matter for a home system with one user who is root anyway, but
it's a really stupid design. A simple work around is to combine the
two scripts into one and thus avoid the environment variables.

--Mark

< Previous 1 Next >

Site Contents