Message Board -  Archive

[ Login ] [ Create Account ]
[ Board List ] [ View Board ] [ Post Reply ]
  Author  Subject: Re: A-Z Net dialup

Posted on 05-12-2003 07:03 p.m. ET  reply

Original Poster: Mark Krentel

> I just installed Mandrake 9.0. I'm trying to dialup to a-znet ( www.a-
> ) I went into kppp and filled in all the settings. It dials
> up fine, put I can't browse or ping anything except the ip kppp says
> is the 'remote computer' and myself. Anybody know what to do?

Well, I can offer the same advice that I always give when this
question is asked (see my responses on May 4 and March 11). Go behind
kppp's back and copy the ppp-on, ppp-off and ppp-on-dialer scripts
from /usr/share/doc/ppp-2.4.1/scripts to /etc/ppp, edit them for your
configuration, and then start and stop PPP with ppp-on and ppp-off.

If you can ping the remote end of the PPP connection but nothing else,
that suggests that you don't have a default route set. I don't know
the kppp way of doing this (since I don't use kppp), but the pppd
option is "defaultroute" (see man pppd). "netstat -rn" will show you
the routing tables which will tell you if that is indeed the problem.

> On another note, Linux is very slow on my machine. I have a K6-350
> with 192 ram, so I am used to sluggishness, but this is rediculous. It
> takes 7 minutes to boot as opposed to 1 to 2 minutes for win 98. App
> windows take like 10 seconds to display. Is this normal? Are there any
> common configuration mistakes that can cause this?

A 350 MHz CPU with 192 Meg RAM should be plenty fast. 7 minutes is
definitely longer than what I'd expect to boot. (But I never reboot
my machine, so how would I know? :-) The boot slowness suggests that
some network daemon is making DNS or other queries when it starts up
and they're timing out. Does the boot pause at a specific point, wait
for 2-5 minutes and then resume? If so, where in the boot sequence?
That would tell you what daemon it is. In Mandrake, you could use
"ntsysv" to turn off unnecessary daemons.

As for general sluggish, I'm not sure. Turning off the L2 cache would
do it, but that would affect every OS (if it's dual boot). When
you're in KDE (or other window manager), open an xterm and start
another simple X application like "xterm" or "xclock". It should come
up instantly. If not, then something is misconfigured, but it's not
immediately clear what. Try "top" to see if some stray process is
consuming 99% of the CPU.


< Previous 1 Next >

Site Contents