Message Board -  Archive

[ Login ] [ Create Account ]
[ Board List ] [ View Board ] [ Post Reply ]
  Author  Subject: KDSKBENT error
Archive  

Posted on 12-01-2004 08:28 a.m. ET  reply

Original Poster: Jim Dishaw

Hi All,

I've posted this to a couple of other forums and have gotten no response and
have taken it as far as I can myself. This regards a Fedora Core 3
installation. Any help would be greatly appreciated.

After doing my updates on November 19, I got a load of errors. Most have been
solved (eggcups, gnome volume manager, nvidia permissions changed by
/etc/udev/permissions.d/50-udev.permissions) but I have been unable to solve
the KDSKBENT error. My FC3 install had been working perfectly for almost two
weeks since I installed it until I did these updates.

On boot (I don't use the rhgb, I boot to runlevel 3) I get the following error
twice:
KDSKBENT failed to bind key 255 to value 2639

It appears right after loading sysstat and again after irqbalance. After I
start X it also appears if I open a virtual terminal, but not if I start an
xterm. I am running FC3 with a stock 2.6.9-1.667 kernel.

I googled this and found some similar reports:
http://www.redhat.com/archives/fedora-list/2004-September/msg00926.html
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=125133

but they offered no solutions and weren't perfect matches to my issue.

I put some echo statements in my /etc/profile and was able to narrow the issue
down to something in my initscripts. I then checked my /var/cache/apt/archives
and confirmed that initscripts had been updated on the day in question. My
first attempt to correct the problem was to download and install the earlier
version of initscripts with:
rpm -Uvh --oldpackage initscripts-7.93.2-1.i386.rpm
but this did not correct the problem.

So I restored the current version of initscripts
(initscripts_7.93.5-1_i386.rpm) and went back to my /etc/profile. I honed it
down (again by inserting echo statements) to my /etc/profile.d. By moving into
/etc/profile.d and putting an echo <filename> into each of the .sh scripts
there, I was able to narrow it down to my /etc/profile.d/lang.sh file. I was
then able to narrow it down further to the section in that file that dealt
with UTF8 and the /bin/unicode_start script.

I worked with the /bin/unicode_start file and found that by commenting out the
line:
dumpkeys | loadkeys --unicode
I could avoid the error.

I did check my /etc/sysconfig/il8n file and that looks good (compared to a
friend's with a similar setup) but my dumpkeys output for key 255 is quite
different:
keycode 255 = nul
altgr control keycode 255 = 0x0a4f
shift alt keycode 255 = VoidSymbol

compared to his:

keycode 255 = nul
altgr control keycode 255 = U+e3cc
shift alt keycode 255 = U+34f1

Other than that, I believe they were identical.

I've gone as far as I can with this, haven't seen others posting about this
issue and really need a bit of help. Everything does seem to be working other
than getting the error messages.

Any help you Linux gurus could provide would be greatly appreciated.

Jim

< Previous 1 Next >

Site Contents