Message Board -  Archive

[ Login ] [ Create Account ]
[ Board List ] [ View Board ] [ Post Reply ]
  Author  Subject: X is no longer showing up
Archive  

Posted on 06-08-2004 08:00 p.m. ET  reply

Original Poster: Mohammed Morsi

Help I'm all out of ideas;

Before I start I would like to thank anyone who helps, I realize this is a
long post but it is a complicated problem (probably with a simple solution).

Also, I just would like you to know that I've exhaused all my resources,
incluing linuxquestions and google/linux as well as fiddling around.

Running: Red Hat 8

Ok the X display will not show at all, that is when I hit ctrl-alt-f7 I get
a blank screen. But I can press ctrl-alt-f[1-6] and get a terminal. So I log
onto the terminal type startx and get:

===========================================
Fatal server error:
Server already running for display 0
If this server ... remove /tmp/.X0-lock ...

When reporting a problem ...

Xlib: connection to ":0.0" refused by sever
Xlib: Invalid MIT-MAGIC-COOKIE-1 key giving up.
xinitd: unable to connect to X server
xinit: no such process (errno 3):Server error

==============================================

(Sorry I can't cut and paste exact errors but I am using a different machine
right now)

So then I type startx -- :1 to see if I can get X working on an alternate
display.... i cant. I switch to ctrl-alt-f8 and I get the black screen, I
switch back to the terminal and see that it cant open the display.

But in the midst of some errors I see the log file is /var/log/XFree86.1.log

So I view this (as well as XFree86.0.log) and find the error:

==============================================
Audit: Tue Jun ...: 983 X: client 4 rejected from local host Auth name: MIT-
MAGIC-COOKIE-1 ID: -1

===============================================

This error appears in both log files, multiple times.

I checked my /etc/X11/XF86Config file, and all looks well (I have not
touched this file in a while).

I have tried other solutions including killing all X-processes, rebooting,
deleting /tmp/X0.lock, and a buch of other stuff that I forgot.

One final note, I believe that the last this I was doing before the 'crash'
was fiddling around with the automounter. But while trying to find the
solution to this problem I disabled automount from staring up by placing
a '.' in front of the file name in the rc5.d directory,

e.g. .S29Autofs

Therefore essentially 'blinding' the startup rc file to see this.

Im all out of Ideas and need help Once again I appreciate all the help I
can get. I have been running RH8 for a couple of months now and am starting
to get comfertable with linux but I am no where near gurudom, so all help is
appreciated.

Thank you so so so so so much;
Mohammed Morsi

(BTW cant wait to the next lug meeting)

< Previous 1 Next >

Site Contents